博客
关于我
强烈建议你试试无所不能的chatGPT,快点击我
背包问题: HDU1114Piggy-Bank
阅读量:6322 次
发布时间:2019-06-22

本文共 3416 字,大约阅读时间需要 11 分钟。

Piggy-Bank

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 25691    Accepted Submission(s): 13023
Problem Description
Before ACM can do anything, a budget must be prepared and the necessary financial support obtained. The main income for this action comes from Irreversibly Bound Money (IBM). The idea behind is simple. Whenever some ACM member has any small money, he takes all the coins and throws them into a piggy-bank. You know that this process is irreversible, the coins cannot be removed without breaking the pig. After a sufficiently long time, there should be enough cash in the piggy-bank to pay everything that needs to be paid. 
But there is a big problem with piggy-banks. It is not possible to determine how much money is inside. So we might break the pig into pieces only to find out that there is not enough money. Clearly, we want to avoid this unpleasant situation. The only possibility is to weigh the piggy-bank and try to guess how many coins are inside. Assume that we are able to determine the weight of the pig exactly and that we know the weights of all coins of a given currency. Then there is some minimum amount of money in the piggy-bank that we can guarantee. Your task is to find out this worst case and determine the minimum amount of cash inside the piggy-bank. We need your help. No more prematurely broken pigs! 
 
Input
The input consists of T test cases. The number of them (T) is given on the first line of the input file. Each test case begins with a line containing two integers E and F. They indicate the weight of an empty pig and of the pig filled with coins. Both weights are given in grams. No pig will weigh more than 10 kg, that means 1 <= E <= F <= 10000. On the second line of each test case, there is an integer number N (1 <= N <= 500) that gives the number of various coins used in the given currency. Following this are exactly N lines, each specifying one coin type. These lines contain two integers each, Pand W (1 <= P <= 50000, 1 <= W <=10000). P is the value of the coin in monetary units, W is it's weight in grams.
 
Output
Print exactly one line of output for each test case. The line must contain the sentence "The minimum amount of money in the piggy-bank is X." where X is the minimum amount of money that can be achieved using coins with the given total weight. If the weight cannot be reached exactly, print a line "This is impossible.".
 
Sample Input
 
3
10 110
2
1 1
10 110
30 50
2 1 1
10 3
50 30 1 6 2
20 4
 
Sample Output
 
The minimum amount of money in the piggy-bank is 60.
The minimum amount of money in the piggy-bank is 100.
This is impossible.
 
Source
#include<iostream>
#include<cstring>
#include<cstdio>
using namespace std;
const int MAXN = 500 + 5;
const int MAXW = 10000 + 5;
const int INF = (1<<30);
int p[MAXN],w[MAXN],dp[MAXN][MAXW];
int main(){
    int T,E,F,n;
    scanf("%d",&T);
    while(T--){
        scanf("%d %d",&E,&F);
        F = F - E;
        scanf("%d",&n);
        for(int i=1;i<=n;i++)
            scanf("%d %d",&p[i],&w[i]);
        for(int i=0;i<=n;i++)
            for(int j=0;j<=F;j++){
                if(j==0) dp[i][0] = 0;
                else dp[i][j] = INF;
            }
        for(int i=1;i<=n;i++)
            for(int j=0;j<=F;j++)
                if(j>=w[i])
                    dp[i][j] = min(dp[i-1][j],dp[i][j-w[i]]+p[i]);
                else
                    dp[i][j] = dp[i-1][j];
        if(dp[n][F]==INF)
            printf("This is impossible.\n");
        else
            printf("The minimum amount of money in the piggy-bank is %d.\n",dp[n][F]);
    }
}

转载于:https://www.cnblogs.com/Pretty9/p/7347715.html

你可能感兴趣的文章
synchronized(this)(转)
查看>>
类别标签处理
查看>>
深度|余凯:基于深度学习的自动驾驶之路
查看>>
ORA-00845: MEMORY_TARGET not supported on this system
查看>>
数据库存储结构
查看>>
国内银行CNAPS CODE 查询 苹果开发者,应用内购,需要填写税务相关信息必须的...
查看>>
Linux下抓图工具shutter
查看>>
javascript获取select,checkbox,radio的值
查看>>
Metro Win8风格的按钮(Filp翻转)
查看>>
cookies/session/token
查看>>
清除代码异味
查看>>
【转】从知乎上看到“全栈开发者”讨论之后的自黑
查看>>
Java-IO流
查看>>
Linux入门-6 Linux网络基本配置
查看>>
洗礼灵魂,修炼python(22)--自定义函数(3)—函数作用域,闭包
查看>>
newcoder Tachibana Kanade Loves Probability(小数点后第k位)题解
查看>>
vue项目未加载完成前显示loading...
查看>>
windows 与linux 下用C++读取sqlite实现文件复制(一)
查看>>
IOS 5 中为什么outlet 输出口总是设定成弱类型(weak)呢
查看>>
Read-Copy Update (RCU)
查看>>